Collection: Products
* All prices exclude GST & Freight, Calculated at checkout *
-
Shireen Inc RFC195 Cable 1000ft Spool 50 Ohm Coax Cable
Vendor:ShireenRegular price $936.00 NZDRegular priceSale price $936.00 NZD -
Shireen Inc RFC240 Cable 1000ft. Spool 50 Ohm Coax Cable Drum
Vendor:ShireenRegular price $1,123.00 NZDRegular priceSale price $1,123.00 NZD -
Shireen Inc RFC240 Cable 50 Ohm Coax Cable Per Metre
Vendor:ShireenRegular price $7.00 NZDRegular priceSale price $7.00 NZD -
Shireen Outdoor CAT6 FTP Shielded Cable per meter
Vendor:ShireenRegular price $2.90 NZDRegular priceSale price $2.90 NZD -
Shireen Outdoor Shielded Cat5e Dry Gel Tape Cable Per meter
Vendor:ShireenRegular price $2.90 NZDRegular priceSale price $2.90 NZD -
Shireen RFC195 50ohm Coax Cable Per Metre
Vendor:ShireenRegular price $5.00 NZDRegular priceSale price $5.00 NZD -
Shireen RFC400 50 Ohm Coax Cable Per Metre
Vendor:ShireenRegular price $9.00 NZDRegular priceSale price $9.00 NZD -
Shireen RFC400 Cable 1000ft Spool 50 Ohm Coax Cable
Vendor:ShireenRegular price $1,619.00 NZDRegular priceSale price $1,619.00 NZD -
Shireen RFC400 Cable 500ft Spool 50 Ohm Coax Cable
Vendor:ShireenRegular price $894.00 NZDRegular priceSale price $894.00 NZD -
Shireen SmartFeed CAT6 Shielded RJ45 Connectors (100Pk)
Vendor:ShireenRegular price $215.00 NZDRegular priceSale price $215.00 NZD -
Shuttle DH610 i3-12100 8GB M.2 256GB SSD Assembled
Vendor:ShuttleRegular price $1,252.00 NZDRegular priceSale price $1,252.00 NZDSold out -
Shuttle DH610 i3-14100 8GB M.2 256GB SSD Windows 10 IoT
Vendor:ShuttleRegular price $1,681.33 NZDRegular priceSale price $1,681.33 NZDSold out -
Shuttle DH770 LGA1700 DDR5 M.2 Slim Barebones PC 2GbE
Vendor:ShuttleRegular price $980.00 NZDRegular priceSale price $980.00 NZD -
Shuttle DL30N N100 Processor Fanless BareBones PC
Vendor:ShuttleRegular price $772.00 NZDRegular priceSale price $772.00 NZD -
Shuttle DN11H5 Ultra 5 125H DDR5 1.3L MINI PC
Vendor:ShuttleRegular price $1,237.33 NZDRegular priceSale price $1,237.33 NZDSold out -
Shuttle DN11H5 Ultra 9 185H DDR5 1.3L MINI PC
Vendor:ShuttleRegular price $2,716.00 NZDRegular priceSale price $2,716.00 NZDSold out -
Shuttle DN11H7 Ultra 7 155H DDR5 1.3L MINI PC
Vendor:ShuttleRegular price $1,477.33 NZDRegular priceSale price $1,477.33 NZDSold out -
Shuttle NC40U Core 7305 Mini Barebones PC XPC Nano
Vendor:ShuttleRegular price $654.67 NZDRegular priceSale price $654.67 NZDSold out -
Shuttle NC40U3 i3-1215U Mini Barebones PC XPC Nano
Vendor:ShuttleRegular price $1,108.00 NZDRegular priceSale price $1,108.00 NZDSold out -
Shuttle NE10N N100 Processor Fanless BareBones PC
Vendor:ShuttleRegular price $529.20 NZDRegular priceSale price $529.20 NZD -
Shuttle SH610R4 LGA1200 Dual Ethernet Barebones Workstation
Vendor:ShuttleRegular price $1,085.33 NZDRegular priceSale price $1,085.33 NZDSold out -
Siklu EtherHaul 1 foot Dish Antenna (FCC/ETSI) with ring adaptor
Vendor:SikluRegular price $295.00 NZDRegular priceSale price $295.00 NZD -
Siklu EtherHaul 2ft dual-band antenna (E-Band Plus 5GHz)
Vendor:SikluRegular price $875.00 NZDRegular priceSale price $875.00 NZD -
Siklu EtherHaul-1200FX ODU TX High with antenna port
Vendor:SikluRegular price $3,249.00 NZDRegular priceSale price $3,249.00 NZD
We're here to assist you
In today's world, safety and protection are paramount, which is why we offer a comprehensive range of cutting-edge security equipment tailored for both commercial and residential applications. Whether you're fortifying your business premises or securing your home, we have the perfect solution to meet your needs.
Latest Technology News Feed
View all-
Why Use Dahua Active Deterrence Cameras? The Ca...
Article Excerpt: Dahua Active Deterrence cameras combine WizSense AI, strobe lights, and sirens to proactively deter intruders across New Zealand commercial, industrial, and residential sites — available in both IP...
Why Use Dahua Active Deterrence Cameras? The Ca...
Article Excerpt: Dahua Active Deterrence cameras combine WizSense AI, strobe lights, and sirens to proactively deter intruders across New Zealand commercial, industrial, and residential sites — available in both IP...
-
Arrowhead Alarm Products EC Security Alarm Kits...
Arrowhead Alarm Products EC Security Alarm Kitsets: Your Comprehensive Guide to Home Security When it comes to safeguarding your home and loved ones, a reliable security system is paramount. Arrowhead...
Arrowhead Alarm Products EC Security Alarm Kits...
Arrowhead Alarm Products EC Security Alarm Kitsets: Your Comprehensive Guide to Home Security When it comes to safeguarding your home and loved ones, a reliable security system is paramount. Arrowhead...
-
TVT-8CHNVRKIT-B-AI-6MP - The Ultimate Guide to ...
Introducing the TVT-8CHNVRKIT-B-AI-6MP: Your Comprehensive Security Solution The TVT-8CHNVRKIT-B-AI-6MP is an advanced 8-channel NVR kit designed to deliver unparalleled security and peace of mind. This powerful system combines cutting-edge technology...
TVT-8CHNVRKIT-B-AI-6MP - The Ultimate Guide to ...
Introducing the TVT-8CHNVRKIT-B-AI-6MP: Your Comprehensive Security Solution The TVT-8CHNVRKIT-B-AI-6MP is an advanced 8-channel NVR kit designed to deliver unparalleled security and peace of mind. This powerful system combines cutting-edge technology...
-
What is a Home Mesh WiFi 6 System? Everything Y...
What is a Home Mesh WiFi 6 System? In today's digital age, reliable and fast internet access is essential. But what happens when your home's Wi-Fi signal struggles to reach...
What is a Home Mesh WiFi 6 System? Everything Y...
What is a Home Mesh WiFi 6 System? In today's digital age, reliable and fast internet access is essential. But what happens when your home's Wi-Fi signal struggles to reach...